You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/wayland-scanner/wayland-scanner-1.22.0.ebuild

45 lines
1023 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
if [[ ${PV} = *9999* ]]; then
EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/wayland.git"
inherit git-r3
else
SRC_URI="https://gitlab.freedesktop.org/wayland/wayland/-/releases/${PV}/downloads/wayland-${PV}.tar.xz"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
S="${WORKDIR}/wayland-${PV}"
fi
inherit meson
DESCRIPTION="wayland-scanner tool"
HOMEPAGE="https://wayland.freedesktop.org/ https://gitlab.freedesktop.org/wayland/wayland"
LICENSE="MIT"
SLOT="0"
BDEPEND="virtual/pkgconfig"
RDEPEND="
!<dev-libs/wayland-${PV}
>=dev-libs/expat-2.1.0-r3
"
DEPEND="${RDEPEND}"
src_configure() {
local emesonargs=(
-Ddocumentation=false
-Ddtd_validation=false
-Dlibraries=false
-Dscanner=true
-Dtests=false
)
meson_src_configure
}
src_install() {
meson_src_install
mv "${ED}"/usr/$(get_libdir)/pkgconfig "${ED}"/usr/share/pkgconfig
}