You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/xxdi/xxdi-1.0.0.ebuild

24 lines
527 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
MODULE_VERSION=001
DESCRIPTION="Simple alternative to vim's 'xxd -i' mode"
HOMEPAGE="https://github.com/gregkh/xxdi"
SRC_URI="https://github.com/gregkh/xxdi/archive/v${MODULE_VERSION}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}"/${PN}-${MODULE_VERSION}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 arm64 ppc ppc64 ~riscv x86"
RDEPEND="dev-lang/perl
dev-perl/File-Slurp"
src_install() {
dobin xxdi.pl
dodoc README.md
}