You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-board/grhino/grhino-0.16.1-r2.ebuild

35 lines
675 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="Reversi game for GNOME, supporting the Go/Game Text Protocol"
HOMEPAGE="https://rhino.sourceforge.net/"
SRC_URI="mirror://sourceforge/rhino/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="nls"
RDEPEND="
nls? ( virtual/libintl )
"
DEPEND="${RDEPEND}"
BDEPEND="nls? ( sys-devel/gettext )"
src_prepare() {
default
sed -i '/^(\|locale\|help\|omf\|icon\|)/s:@datadir@:/usr/share:' \
Makefile.in || die
}
src_configure() {
econf \
--localedir=/usr/share/locale \
--enable-gtp \
--disable-gnome \
$(use_enable nls)
}