You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-board/hexxagon/hexxagon-1.0.2-r1.ebuild

37 lines
637 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit desktop toolchain-funcs
DESCRIPTION="Clone of the original DOS game"
HOMEPAGE="https://www.nesqi.se/"
SRC_URI="https://www.nesqi.se/download/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
dev-cpp/glibmm:2
dev-cpp/gtkmm:2.4
x11-libs/gtk+:2"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${P}-glibc-2.31.patch
)
src_compile() {
emake AR="$(tc-getAR)"
}
src_install() {
default
newicon images/board_N_2.xpm ${PN}.xpm
make_desktop_entry ${PN} Hexxagon
}