You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-misc/fortune-mod-it/fortune-mod-it-1.99.ebuild

38 lines
770 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="Database of the Italian cookies for the fortune program"
HOMEPAGE="http://www.fortune-it.net/"
SRC_URI="http://www.fortune-it.net/download/fortune-it-${PVR}.tar.gz"
S="${WORKDIR}"/fortune-it-${PVR}
LICENSE="freedist"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="offensive"
DEPEND="games-misc/fortune-mod"
src_prepare() {
default
if ! use offensive ; then
rm -f testi/*-o || die
fi
}
src_compile() {
local f
for f in testi/* ; do
strfile -s ${f} || die "strfile ${f} failed"
done
}
src_install() {
insinto /usr/share/fortune
doins testi/*
dodoc README
}