You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-misc/openmsx/openmsx-0.4.2.ebuild

28 lines
687 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{9..12} )
inherit python-any-r1
DESCRIPTION="Open source music base set for OpenTTD"
HOMEPAGE="https://wiki.openttd.org/en/Basesets/OpenMSX https://github.com/OpenTTD/OpenMSX"
SRC_URI="https://cdn.openttd.org/openmsx-releases/${PV}/${P}-source.tar.xz"
S="${WORKDIR}/${P}-source"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
# Don't appear to be meaningful
RESTRICT="test"
BDEPEND="${PYTHON_DEPS}"
src_install() {
insinto /usr/share/openttd/baseset/${P}
doins ${P}/{*.mid,openmsx.obm}
dodoc ${P}/{changelog,readme}.txt
}