You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-puzzle/hexalate/hexalate-1.1.6.ebuild

42 lines
639 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit qmake-utils xdg-utils
DESCRIPTION="A color matching game"
HOMEPAGE="https://gottcode.org/hexalate/"
SRC_URI="https://gottcode.org/${PN}/${P}-src.tar.bz2"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
BDEPEND="
dev-qt/linguist-tools:5
"
RDEPEND="
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
"
DEPEND="${RDEPEND}"
src_configure() {
eqmake5 PREFIX="/usr"
}
src_install() {
emake INSTALL_ROOT="${D}" install
}
pkg_postinst() {
xdg_icon_cache_update
}
pkg_postrm() {
xdg_icon_cache_update
}