You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/gnome-base/gnome-menus/gnome-menus-3.36.0-r1.ebuild

36 lines
884 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit gnome2
DESCRIPTION="Library and layout configuration for the Desktop Menu fd.o specification"
HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-menus"
LICENSE="GPL-2+ LGPL-2+"
SLOT="3"
KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~loong ppc ~ppc64 ~riscv ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="+introspection test"
RESTRICT="!test? ( test )"
RDEPEND="
>=dev-libs/glib-2.29.15:2
introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
"
DEPEND="${RDEPEND}
test? ( dev-libs/gjs )
"
BDEPEND="
>=sys-devel/gettext-0.19.4
virtual/pkgconfig
"
DOCS=( AUTHORS ChangeLog HACKING NEWS README )
src_configure() {
# Do NOT compile with --disable-debug/--enable-debug=no
# It disables api usage checks
gnome2_src_configure $(use_enable introspection)
}