You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-frameworks/kdbusaddons/kdbusaddons-6.1.0.ebuild

31 lines
614 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
QTMIN=6.6.2
VIRTUALDBUS_TEST="true"
inherit ecm frameworks.kde.org
DESCRIPTION="Framework for registering services and applications per freedesktop standards"
LICENSE="LGPL-2+"
KEYWORDS="~amd64"
IUSE="X"
# slot op: Uses Qt6::GuiPrivate for qtx11extras_p.h
DEPEND="
>=dev-qt/qtbase-${QTMIN}:6[dbus]
X? ( >=dev-qt/qtbase-${QTMIN}:6=[gui] )
"
RDEPEND="${DEPEND}"
BDEPEND=">=dev-qt/qttools-${QTMIN}:6[linguist]"
src_configure() {
local mycmakeargs=(
-DWITH_X11=$(usex X)
)
ecm_src_configure
}