You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-frameworks/kded/kded-6.1.0.ebuild

36 lines
753 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
ECM_QTHELP="false"
ECM_TEST="false"
PVCUT=$(ver_cut 1-2)
QTMIN=6.6.2
inherit ecm frameworks.kde.org
DESCRIPTION="Central daemon of KDE workspaces"
LICENSE="LGPL-2+"
KEYWORDS="~amd64"
IUSE="+man"
DEPEND="
>=dev-qt/qtbase-${QTMIN}:6[dbus,gui,widgets]
=kde-frameworks/kconfig-${PVCUT}*:6[dbus]
=kde-frameworks/kcoreaddons-${PVCUT}*:6
=kde-frameworks/kcrash-${PVCUT}*:6
=kde-frameworks/kdbusaddons-${PVCUT}*:6
=kde-frameworks/kservice-${PVCUT}*:6
"
RDEPEND="${DEPEND}"
BDEPEND="man? ( >=kde-frameworks/kdoctools-${PVCUT}:6 )"
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package man KF6DocTools)
)
ecm_src_configure
}