You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-frameworks/kdesu/kdesu-6.1.0.ebuild

34 lines
612 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
ECM_TEST="true"
PVCUT=$(ver_cut 1-2)
inherit ecm frameworks.kde.org
DESCRIPTION="Framework to handle super user actions"
LICENSE="LGPL-2"
KEYWORDS="~amd64"
IUSE="X"
RDEPEND="
=kde-frameworks/kconfig-${PVCUT}*:6
=kde-frameworks/kcoreaddons-${PVCUT}*:6
=kde-frameworks/ki18n-${PVCUT}*:6
=kde-frameworks/kpty-${PVCUT}*:6
X? ( x11-libs/libX11 )
"
DEPEND="${RDEPEND}
X? ( x11-base/xorg-proto )
"
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package X X11)
)
ecm_src_configure
}