You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-frameworks/kitemmodels/kitemmodels-5.115.0.ebuild

32 lines
616 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
QTMIN=5.15.9
inherit ecm frameworks.kde.org
DESCRIPTION="Framework providing data models to help with tasks such as sorting and filtering"
LICENSE="LGPL-2+"
KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86"
IUSE="qml"
RDEPEND="
qml? ( >=dev-qt/qtdeclarative-${QTMIN}:5 )
"
DEPEND="${RDEPEND}
test? ( >=dev-qt/qtwidgets-${QTMIN}:5 )
"
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package qml Qt5Qml)
)
ecm_src_configure
}
src_test() {
LC_NUMERIC="C" ecm_src_test # bug 708820
}