You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-frameworks/knotifyconfig/knotifyconfig-6.1.0.ebuild

34 lines
723 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
ECM_TEST="false"
PVCUT=$(ver_cut 1-2)
QTMIN=6.6.2
inherit ecm frameworks.kde.org
DESCRIPTION="Framework for configuring desktop notifications"
LICENSE="LGPL-2+"
KEYWORDS="~amd64"
IUSE="phonon"
DEPEND="
>=dev-qt/qtbase-${QTMIN}:6[dbus,gui,widgets]
=kde-frameworks/kcompletion-${PVCUT}*:6
=kde-frameworks/kconfig-${PVCUT}*:6
=kde-frameworks/ki18n-${PVCUT}*:6
=kde-frameworks/kio-${PVCUT}*:6
!phonon? ( media-libs/libcanberra )
phonon? ( >=media-libs/phonon-4.12.0[qt6] )
"
RDEPEND="${DEPEND}"
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package !phonon Canberra)
)
ecm_src_configure
}