You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-frameworks/kquickcharts/kquickcharts-5.115.0.ebuild

40 lines
849 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
ECM_EXAMPLES="true"
ECM_QTHELP="false"
ECM_TEST="true"
PVCUT=$(ver_cut 1-2)
QTMIN=5.15.9
VIRTUALX_REQUIRED="test" # bug 910062 (tests fail)
inherit ecm frameworks.kde.org
DESCRIPTION="QtQuick plugin providing high-performance charts"
HOMEPAGE="https://invent.kde.org/frameworks/kquickcharts"
LICENSE="LGPL-2+"
KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86"
IUSE=""
DEPEND="
>=dev-qt/qtgui-${QTMIN}:5
>=dev-qt/qtdeclarative-${QTMIN}:5
>=dev-qt/qtquickcontrols2-${QTMIN}:5
examples? (
>=dev-qt/qtwidgets-${QTMIN}:5
=kde-frameworks/kdeclarative-${PVCUT}*:5
=kde-frameworks/kirigami-${PVCUT}*:5
)
"
RDEPEND="${DEPEND}"
src_configure() {
local mycmakeargs=(
-DBUILD_EXAMPLES=$(usex examples)
)
ecm_src_configure
}