You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-frameworks/kunitconversion/kunitconversion-5.115.0.ebuild

34 lines
675 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PVCUT=$(ver_cut 1-2)
QTMIN=5.15.9
inherit ecm frameworks.kde.org
DESCRIPTION="Framework for converting units"
LICENSE="LGPL-2+"
KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86"
IUSE=""
DEPEND="
>=dev-qt/qtnetwork-${QTMIN}:5
=kde-frameworks/ki18n-${PVCUT}*:5
"
RDEPEND="${DEPEND}"
src_test() {
local CMAKE_SKIP_TESTS=(
# bug 623938 - needs internet connection
convertertest
# bug 808216 - needs internet connection
categorytest
# bug 808216 - unknown, reported upstream
currencytableinittest
)
LC_NUMERIC="C" ecm_src_test # bug 694804
}