You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-plasma/kwayland/kwayland-5.115.0.ebuild

45 lines
1.0 KiB

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
ECM_NONGUI="true"
ECM_QTHELP="true"
ECM_TEST="true"
KFMIN=$(ver_cut 1-2)
QTMIN=5.15.9
inherit ecm flag-o-matic frameworks.kde.org
DESCRIPTION="Qt-style client and server library wrapper for Wayland libraries"
HOMEPAGE="https://invent.kde.org/frameworks/kwayland"
LICENSE="LGPL-2.1"
KEYWORDS="amd64 arm arm64 ~loong ppc64 ~riscv x86"
IUSE=""
# All failing, I guess we need a virtual wayland server
RESTRICT="test"
# slot ops: includes qpa/qplatformnativeinterface.h, surface_p.h
RDEPEND="
>=dev-libs/wayland-1.15.0
>=dev-qt/qtconcurrent-${QTMIN}:5
>=dev-qt/qtgui-${QTMIN}:5=[egl]
>=dev-qt/qtwayland-${QTMIN}:5=
media-libs/libglvnd
"
DEPEND="${RDEPEND}
>=dev-libs/plasma-wayland-protocols-1.9.0
>=dev-libs/wayland-protocols-1.15
sys-kernel/linux-headers
"
BDEPEND="
>=dev-qt/qtwaylandscanner-${QTMIN}:5
>=dev-util/wayland-scanner-1.19.0
"
src_configure() {
filter-lto # bug 866575
ecm_src_configure
}