You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-plasma/layer-shell-qt/layer-shell-qt-6.0.4.ebuild

32 lines
628 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
KFMIN=6.0
QTMIN=6.6.2
inherit ecm plasma.kde.org
DESCRIPTION="Qt component to allow applications make use of Wayland wl-layer-shell protocol"
LICENSE="LGPL-3+"
SLOT="6"
KEYWORDS="~amd64"
IUSE=""
# slot op: various private QtWaylandClient headers
RDEPEND="
>=dev-libs/wayland-1.15
>=dev-qt/qtbase-${QTMIN}:6[gui]
>=dev-qt/qtdeclarative-${QTMIN}:6
>=dev-qt/qtwayland-${QTMIN}:6=
x11-libs/libxkbcommon
"
DEPEND="${RDEPEND}
dev-libs/wayland-protocols
"
BDEPEND="
dev-util/wayland-scanner
virtual/pkgconfig
"