You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/lxde-base/lxlauncher/lxlauncher-0.2.5-r1.ebuild

41 lines
780 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="Open source clone of the Asus launcher for EeePC"
HOMEPAGE="https://wiki.lxde.org/en/LXLauncher"
SRC_URI="https://downloads.sourceforge.net/lxde/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~riscv ~x86 ~amd64-linux ~x86-linux"
IUSE=""
RDEPEND="
dev-libs/glib:2
gnome-base/gnome-menus
lxde-base/menu-cache
x11-libs/cairo
x11-libs/gdk-pixbuf:2
x11-libs/gtk+:3
x11-libs/libX11
x11-libs/startup-notification
"
DEPEND="${RDEPEND}"
BDEPEND="
dev-util/intltool
sys-devel/gettext
virtual/pkgconfig
"
src_configure() {
econf \
--enable-gtk3
}
src_install() {
emake DESTDIR="${D}" install
dodoc AUTHORS ChangeLog README
}