You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/mate-base/libmatekbd/libmatekbd-1.26.1.ebuild

50 lines
942 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
MATE_LA_PUNT="yes"
inherit mate
MINOR=$(($(ver_cut 2) % 2))
if [[ ${MINOR} -eq 0 ]]; then
KEYWORDS="amd64 ~arm ~arm64 ~loong ~riscv x86"
fi
DESCRIPTION="MATE keyboard configuration library"
LICENSE="GPL-2+ LGPL-2+"
SLOT="0"
IUSE="X +introspection test"
RESTRICT="!test? ( test )"
COMMON_DEPEND="
>=dev-libs/glib-2.50:2
virtual/libintl
x11-libs/cairo
>=x11-libs/gdk-pixbuf-2.24:2
x11-libs/libX11
>=x11-libs/libxklavier-5.2:0[introspection?]
x11-libs/pango
>=x11-libs/gtk+-3.22:3[introspection?]
introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
"
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}"
BDEPEND="
dev-util/glib-utils
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
"
src_configure() {
mate_src_configure \
$(use_with X x) \
$(use_enable introspection) \
$(use_enable test tests)
}