You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/mate-extra/caja-admin/caja-admin-0.0.5.ebuild

40 lines
862 B

# Copyright 2019-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
if [[ ${PV} == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/infirit/caja-admin"
else
SRC_URI="https://github.com/infirit/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
PYTHON_COMPAT=( python{3_9,3_10,3_11} )
inherit meson python-single-r1
DESCRIPTION="Caja Admin Extension"
HOMEPAGE="https://github.com/infirit/caja-admin"
LICENSE="GPL-3+"
SLOT="0"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
COMMON_DEPEND="${PYTHON_DEPS}"
RDEPEND="${COMMON_DEPEND}
app-editors/pluma
dev-python/python-caja[${PYTHON_SINGLE_USEDEP}]
sys-auth/polkit
x11-terms/mate-terminal
"
BDEPEND="${COMMON_DEPEND}
sys-devel/gettext
"
src_install() {
meson_src_install
python_optimize "${D}/usr/share/caja-python/extensions"
}