You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-gfx/apngdis/apngdis-2.9.ebuild

39 lines
668 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit toolchain-funcs
DESCRIPTION="Extract PNG frames from an APNG"
HOMEPAGE="https://sourceforge.net/projects/apngdis/"
SRC_URI="https://downloads.sourceforge.net/${PN}/${PV}/${P}-src.zip"
S="${WORKDIR}"
LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="media-libs/libpng:0="
DEPEND="${RDEPEND}"
BDEPEND="app-arch/unzip"
PATCHES=(
"${FILESDIR}"/${P}-makefile.patch
"${FILESDIR}"/${P}-zlib.patch
)
src_prepare() {
default
# remove bundled libs
rm -r libpng zlib || die
tc-export CC
}
src_install() {
dobin ${PN}
dodoc readme.txt
}