You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-gfx/apngopt/apngopt-1.4-r1.ebuild

39 lines
667 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit toolchain-funcs
DESCRIPTION="Optimize APNG images"
HOMEPAGE="https://sourceforge.net/projects/apng/"
SRC_URI="https://downloads.sourceforge.net/apng/${P}-src.zip"
S="${WORKDIR}"
LICENSE="LGPL-2.1 ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
app-arch/zopfli:=
media-libs/libpng:=
sys-libs/zlib"
DEPEND="${RDEPEND}"
BDEPEND="app-arch/unzip"
PATCHES=( "${FILESDIR}"/${PF}-makefile.patch )
src_prepare() {
default
rm -rf libpng zlib zopfli || die
}
src_configure() {
tc-export CXX
}
src_install() {
dobin apngopt
dodoc readme.txt
}