You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-gfx/phototonic/phototonic-2.1.ebuild

43 lines
864 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit qmake-utils xdg
DESCRIPTION="Image viewer and organizer"
HOMEPAGE="https://github.com/oferkv/phototonic"
if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/oferkv/phototonic.git"
else
SRC_URI="https://github.com/oferkv/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
LICENSE="GPL-3+"
SLOT="0"
IUSE="svg tiff"
RDEPEND="
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
media-gfx/exiv2:=
svg? ( dev-qt/qtsvg:5 )
tiff? ( dev-qt/qtimageformats:5 )
"
DEPEND="${RDEPEND}"
# pending upstream: https://github.com/oferkv/phototonic/pull/274
PATCHES=( "${FILESDIR}/${P}-exiv2-0.28.patch" ) # bug 906492
src_configure() {
eqmake5
}
src_install() {
emake install INSTALL_ROOT="${D}"
}