You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/cimg/cimg-2.9.3.ebuild

27 lines
593 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="C++ template image processing toolkit"
HOMEPAGE="https://cimg.eu/ https://github.com/GreycLab/CImg"
SRC_URI="https://github.com/GreycLab/CImg/archive/v.${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="CeCILL-2 CeCILL-C"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples"
S="${WORKDIR}/CImg-v.${PV}"
src_install() {
doheader CImg.h
dodoc README.txt
use doc && dodoc -r html
if use examples; then
dodoc -r examples
docompress -x "/usr/share/doc/${PF}/examples"
fi
}