You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/gst-plugins-good/gst-plugins-good-1.22.11.eb...

38 lines
956 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
GST_ORG_MODULE="gst-plugins-good"
inherit gstreamer-meson
DESCRIPTION="Basepack of plugins for GStreamer"
HOMEPAGE="https://gstreamer.freedesktop.org/"
LICENSE="LGPL-2.1+"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~sparc x86"
IUSE="+orc"
# Old media-libs/gst-plugins-ugly blocker for xingmux moving from ugly->good
RDEPEND="
!<media-libs/gst-plugins-ugly-1.22.3
>=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
>=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}]
>=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
orc? ( >=dev-lang/orc-0.4.33[${MULTILIB_USEDEP}] )
"
DEPEND="${RDEPEND}"
DOCS=( AUTHORS ChangeLog NEWS README.md RELEASE )
multilib_src_configure() {
# gst/matroska can use bzip2
GST_PLUGINS_NOAUTO="bz2"
local emesonargs=(
-Dbz2=enabled
)
gstreamer_multilib_src_configure
}