You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/libass/libass-0.16.0.ebuild

43 lines
1.3 KiB

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/libass.asc
inherit multilib-minimal verify-sig
DESCRIPTION="Library for SSA/ASS subtitles rendering"
HOMEPAGE="https://github.com/libass/libass"
SRC_URI="https://github.com/libass/libass/releases/download/${PV}/${P}.tar.xz"
SRC_URI+=" verify-sig? ( https://github.com/libass/libass/releases/download/${PV}/${P}.tar.xz.asc )"
LICENSE="ISC"
SLOT="0/9" # subslot = libass soname version
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="+fontconfig"
BDEPEND="virtual/pkgconfig
amd64? ( dev-lang/nasm )
x86? ( dev-lang/nasm )
verify-sig? ( sec-keys/openpgp-keys-libass )"
RDEPEND=">=dev-libs/fribidi-0.19.5-r1[${MULTILIB_USEDEP}]
>=media-libs/freetype-2.5.0.1:2[${MULTILIB_USEDEP}]
>=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
>=media-libs/harfbuzz-1.2.3:=[truetype,${MULTILIB_USEDEP}]
fontconfig? ( >=media-libs/fontconfig-2.10.92[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}"
DOCS=( Changelog )
multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
$(use_enable fontconfig) \
--disable-require-system-font-provider
}
multilib_src_install_all() {
einstalldocs
find "${ED}" -name '*.la' -type f -delete || die
}