You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/libemf/libemf-1.0.13.ebuild

26 lines
655 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="Library implementation of ECMA-234 API for the generation of enhanced metafiles"
HOMEPAGE="http://libemf.sourceforge.net/"
SRC_URI="https://downloads.sourceforge.net/libemf/${P}.tar.gz"
LICENSE="LGPL-2.1 GPL-2"
SLOT="0"
KEYWORDS="amd64 -arm ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
IUSE="doc static-libs"
src_configure() {
econf \
--enable-editing \
$(use_enable static-libs static)
}
src_install() {
use doc && HTML_DOCS=( doc/html/. )
default
use static-libs || find "${D}" -name '*.la' -type f -delete
}