You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/libfishsound/libfishsound-1.0.0-r2.ebuild

53 lines
1.0 KiB

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DESCRIPTION="Simple programming interface to decode and encode audio with vorbis or speex"
HOMEPAGE="https://www.xiph.org/fishsound/"
SRC_URI="https://downloads.xiph.org/releases/libfishsound/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="flac speex"
RDEPEND="
media-libs/libogg
media-libs/libvorbis
flac? ( media-libs/flac:= )
speex? ( media-libs/speex )
"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
# bug #395153
RESTRICT="test"
PATCHES=(
"${FILESDIR}"/${P}-pc.patch
"${FILESDIR}"/${PN}-1.0.0-c99.patch
)
src_prepare() {
default
sed -i \
-e 's:doxygen:doxygen-dummy:' \
configure || die
}
src_configure() {
local myconf="--disable-static"
use flac || myconf="${myconf} --disable-flac"
use speex || myconf="${myconf} --disable-speex"
econf ${myconf}
}
src_install() {
emake DESTDIR="${D}" \
docdir="${D}/usr/share/doc/${PF}" install
dodoc AUTHORS ChangeLog README
find "${ED}" -name '*.la' -delete || die
}