You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/libharu/libharu-2.4.2-r1.ebuild

33 lines
687 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit cmake
DESCRIPTION="C/C++ library for PDF generation"
HOMEPAGE="http://www.libharu.org/"
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="ZLIB"
SLOT="0/${PV}"
KEYWORDS="amd64 ~arm ~arm64 ppc ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
DEPEND="
media-libs/libpng:=
sys-libs/zlib:=
"
RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-2.3.0-1-Included-necessary-char-widths-in-generated-PDF.patch
)
src_configure() {
local mycmakeargs=(
-DLIBHPDF_EXAMPLES=NO # Doesn't work
-DLIBHPDF_STATIC=NO
)
cmake_src_configure
}