You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/libmpris2client/libmpris2client-0.1.0-r1.eb...

39 lines
717 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit gnome2-utils
DESCRIPTION="A library to control MPRIS2 compatible players"
HOMEPAGE="https://github.com/matiasdelellis/libmpris2client"
SRC_URI="https://github.com/matiasdelellis/${PN}/releases/download/V${PV}/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 x86"
RDEPEND=">=dev-libs/glib-2
x11-libs/gtk+:2"
DEPEND="${RDEPEND}
virtual/pkgconfig"
DOCS=( AUTHORS NEWS README TODO )
src_configure() {
econf --disable-static
}
src_install() {
default
find "${ED}" -name '*.la' -delete || die
}
pkg_postinst() {
gnome2_icon_cache_update
}
pkg_postrm() {
gnome2_icon_cache_update
}