You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/libnsbmp/libnsbmp-0.1.7.ebuild

32 lines
671 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit netsurf
DESCRIPTION="Decoding library for BMP and ICO image file formats, written in C"
HOMEPAGE="https://www.netsurf-browser.org/projects/libnsbmp/"
SRC_URI="https://download.netsurf-browser.org/libs/releases/${P}-src.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
BDEPEND="
dev-build/netsurf-buildsystem
virtual/pkgconfig"
_emake() {
netsurf_define_makeconf
emake "${NETSURF_MAKECONF[@]}" COMPONENT_TYPE=lib-shared $@
}
src_compile() {
_emake
}
src_install() {
_emake DESTDIR="${D}" install
}