You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/libsidplayfp/libsidplayfp-2.7.0.ebuild

30 lines
685 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DESCRIPTION="Library for the sidplay2 fork with resid-fp"
HOMEPAGE="https://sourceforge.net/projects/sidplay-residfp/"
SRC_URI="https://downloads.sourceforge.net/sidplay-residfp/${PN}/$(ver_cut 1-2)/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0/6"
KEYWORDS="amd64 ~hppa ~riscv x86"
IUSE="static-libs"
src_prepare() {
default
# fix automagic. warning: modifying .ac triggers maintainer mode.
sed -i -e 's:doxygen:dIsAbLe&:' configure || die
}
src_configure() {
econf \
$(use_enable static-libs static)
}
src_install() {
default
find "${D}" -name '*.la' -delete || die
}