You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/mutagen/mutagen-1.47.0.ebuild

37 lines
823 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
DESCRIPTION="Audio metadata tag reader and writer implemented in pure Python"
HOMEPAGE="
https://github.com/quodlibet/mutagen/
https://pypi.org/project/mutagen/
"
SRC_URI="
https://github.com/quodlibet/mutagen/releases/download/release-${PV}/${P}.tar.gz
"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
BDEPEND="
test? (
dev-python/eyeD3[${PYTHON_USEDEP}]
dev-python/hypothesis[${PYTHON_USEDEP}]
media-libs/flac[ogg]
)
"
DOCS=( NEWS README.rst )
distutils_enable_tests pytest
distutils_enable_sphinx docs \
dev-python/sphinx-rtd-theme