You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-plugins/g2reverb/g2reverb-0.7.1.ebuild

31 lines
630 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit toolchain-funcs
DESCRIPTION="Stereo reverb LADSPA plugin"
HOMEPAGE="http://kokkinizita.linuxaudio.org/linuxaudio/"
SRC_URI="http://kokkinizita.linuxaudio.org/linuxaudio/downloads/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
DEPEND="media-libs/ladspa-sdk"
RDEPEND="${DEPEND}"
src_prepare() {
default
tc-export CXX
sed -i Makefile -e 's/-O2//' -e 's/g++/$(CXX) $(LDFLAGS)/' || die
}
src_install() {
dodoc AUTHORS README
insinto /usr/$(get_libdir)/ladspa
insopts -m0755
doins *.so
}