You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-plugins/gst-plugins-a52dec/gst-plugins-a52dec-1.22.11....

26 lines
567 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
GST_ORG_MODULE=gst-plugins-ugly
inherit gstreamer-meson
DESCRIPTION="ATSC A/52 audio decoder plugin for GStreamer"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~sparc x86"
IUSE="+orc"
RDEPEND="
>=media-libs/a52dec-0.7.4-r6[${MULTILIB_USEDEP}]
orc? ( >=dev-lang/orc-0.4.33[${MULTILIB_USEDEP}] )
"
DEPEND="${RDEPEND}"
multilib_src_configure() {
local emesonargs=(
-Dgpl=enabled
)
gstreamer_multilib_src_configure
}