You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-plugins/gst-plugins-adaptivedemux2/gst-plugins-adaptivedemux2-...

31 lines
550 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
GST_ORG_MODULE=gst-plugins-good
inherit gstreamer-meson
DESCRIPTION="Adaptive demuxer plugins for Gstreamer"
KEYWORDS="amd64 arm64"
RDEPEND="
>=dev-libs/libxml2-2.8[${MULTILIB_USEDEP}]
dev-libs/nettle:0=[${MULTILIB_USEDEP}]
"
DEPEND="${RDEPEND}"
RDEPEND="${RDEPEND}
|| (
net-libs/libsoup:3.0
net-libs/libsoup:2.4
)
"
multilib_src_configure() {
local emesonargs=(
-Dhls-crypto=nettle
)
gstreamer_multilib_src_configure
}