You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-plugins/gst-plugins-dts/gst-plugins-dts-1.22.11.ebuild

26 lines
539 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
GST_ORG_MODULE=gst-plugins-bad
inherit gstreamer-meson
DESCRIPTION="DTS audio decoder plugin for Gstreamer"
KEYWORDS="amd64 ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv x86"
IUSE="+orc"
RDEPEND="
>=media-libs/libdca-0.0.5-r3[${MULTILIB_USEDEP}]
orc? ( >=dev-lang/orc-0.4.33[${MULTILIB_USEDEP}] )
"
DEPEND="${RDEPEND}"
multilib_src_configure() {
local emesonargs=(
-Dgpl=enabled
)
gstreamer_multilib_src_configure
}