You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-plugins/gst-plugins-opus/gst-plugins-opus-1.22.11.eb...

49 lines
1.5 KiB

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
GST_ORG_MODULE=gst-plugins-base
inherit gstreamer-meson
DESCRIPTION="Opus audio parser plugin for GStreamer"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~sparc x86"
COMMON_DEPEND=">=media-libs/opus-1.1:=[${MULTILIB_USEDEP}]"
RDEPEND="${COMMON_DEPEND}
>=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},ogg]
"
DEPEND="${COMMON_DEPEND}"
src_prepare() {
default
gstreamer_system_package audio_dep:gstreamer-audio \
pbutils_dep:gstreamer-pbutils \
tag_dep:gstreamer-tag
}
# Everything below is for building opusparse from gst-plugins-bad. Once it moves into -base, all below can be removed
SRC_URI+=" https://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-${PV}.tar.${GST_TARBALL_SUFFIX}"
in_bdir() {
pushd "${BUILD_DIR}" || die
"$@"
popd || die
}
src_configure() {
S="${WORKDIR}/gst-plugins-base-${PV}" multilib_foreach_abi gstreamer_multilib_src_configure
S="${WORKDIR}/gst-plugins-bad-${PV}" multilib_foreach_abi gstreamer_multilib_src_configure
}
src_compile() {
S="${WORKDIR}/gst-plugins-base-${PV}" multilib_foreach_abi in_bdir gstreamer_multilib_src_compile
S="${WORKDIR}/gst-plugins-bad-${PV}" multilib_foreach_abi in_bdir gstreamer_multilib_src_compile
}
src_install() {
S="${WORKDIR}/gst-plugins-base-${PV}" multilib_foreach_abi in_bdir gstreamer_multilib_src_install
S="${WORKDIR}/gst-plugins-bad-${PV}" multilib_foreach_abi in_bdir gstreamer_multilib_src_install
}