You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-plugins/imlib2_loaders/imlib2_loaders-1.12.2.ebuild

35 lines
779 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DESCRIPTION="Additional image loaders for Imlib2"
HOMEPAGE="https://www.enlightenment.org/
https://sourceforge.net/projects/enlightenment/files/imlib2-src/"
SRC_URI="https://downloads.sourceforge.net/enlightenment/${P}.tar.xz"
LICENSE="|| ( BSD GPL-2 )"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris"
IUSE="xcf"
RDEPEND=">=media-libs/imlib2-${PV}"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
src_configure() {
local myconf=(
--disable-static
$(use_enable xcf)
)
econf "${myconf[@]}"
}
src_install() {
V=1 emake install DESTDIR="${D}"
einstalldocs
find "${D}" -name '*.la' -delete || die
}