You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-plugins/kodi-audioencoder-vorbis/kodi-audioencoder-vorbis-19...

45 lines
860 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit cmake kodi-addon
DESCRIPTION="Vorbis encoder addon for Kodi"
HOMEPAGE="https://github.com/xbmc/audioencoder.vorbis"
SRC_URI=""
case ${PV} in
9999)
SRC_URI=""
EGIT_REPO_URI="https://github.com/xbmc/audioencoder.vorbis.git"
inherit git-r3
DEPEND="~media-tv/kodi-9999"
;;
*)
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
CODENAME="Matrix"
SRC_URI="https://github.com/xbmc/audioencoder.vorbis/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/audioencoder.vorbis-${PV}-${CODENAME}"
DEPEND="=media-tv/kodi-19*"
;;
esac
LICENSE="GPL-2+"
SLOT="0"
IUSE=""
DEPEND+="
>=media-libs/libogg-1.3.5
>=media-libs/libvorbis-1.3.6
"
RDEPEND="
${DEPEND}
"
src_prepare() {
[ -d depends ] && rm -rf depends || die
cmake_src_prepare
}