You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-plugins/kodi-inputstream-rtmp/kodi-inputstream-rtmp-9999....

46 lines
894 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit kodi-addon
DESCRIPTION="Kodi's RTMP inputstream addon"
HOMEPAGE="https://github.com/xbmc/inputstream.rtmp"
KODI_PLUGIN_NAME="inputstream.rtmp"
case ${PV} in
9999)
SRC_URI=""
EGIT_REPO_URI="https://github.com/xbmc/${KODI_PLUGIN_NAME}.git"
EGIT_BRANCH="Matrix"
inherit git-r3
DEPEND="~media-tv/kodi-9999"
;;
*)
CODENAME="Matrix"
KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/xbmc/${KODI_PLUGIN_NAME}/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/${KODI_PLUGIN_NAME}-${PV}-${CODENAME}"
DEPEND="=media-tv/kodi-19*:="
;;
esac
LICENSE="GPL-2+"
SLOT="0"
IUSE=""
DEPEND+="
media-video/rtmpdump[ssl]
"
RDEPEND="${DEPEND}"
BDEPEND="virtual/pkgconfig"
src_prepare() {
if [ -d depends ]; then rm -rf depends || die; fi
cmake_src_prepare
}