You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-plugins/kodi-vfs-rar/kodi-vfs-rar-4.0.0.ebuild

38 lines
695 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit cmake kodi-addon
DESCRIPTION="RAR VFS addon for Kodi"
HOMEPAGE="https://github.com/xbmc/vfs.rar"
SRC_URI=""
case ${PV} in
9999)
SRC_URI=""
EGIT_REPO_URI="https://github.com/xbmc/vfs.rar.git"
EGIT_BRANCH="Matrix"
inherit git-r3
DEPEND="~media-tv/kodi-9999"
;;
*)
CODENAME="Matrix"
KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/xbmc/vfs.rar/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/vfs.rar-${PV}-${CODENAME}"
DEPEND="=media-tv/kodi-19*:="
;;
esac
LICENSE="GPL-2+"
SLOT="0"
IUSE=""
DEPEND+="
dev-libs/tinyxml
"
RDEPEND="${DEPEND}"