You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-plugins/vdr-suspendoutput/vdr-suspendoutput-2.0.1-r1....

31 lines
706 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit vdr-plugin-2
DESCRIPTION="VDR Plugin: Show still image instead of live tv to safe cpu"
HOMEPAGE="http://phivdr.dyndns.org/vdr/vdr-suspendoutput/"
SRC_URI="http://phivdr.dyndns.org/vdr/vdr-suspendoutput/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="media-video/vdr"
RDEPEND="${DEPEND}"
src_prepare() {
vdr-plugin-2_src_prepare
# compile fix, wrt bug 574162
sed -e 246c"unsigned int TimeoutMs, bool runOnce)" \
-e 254c"unsigned int TimeoutMs, bool runOnce)" \
-i timer.h || die
# gcc-11, bug 787506
sed -e "s|max|std::max|" -i timer.c || die
}