You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-sound/id3v2/id3v2-0.1.12-r1.ebuild

33 lines
540 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="Command line editor for id3v2 tags"
HOMEPAGE="https://id3v2.sourceforge.net/"
SRC_URI="mirror://sourceforge/id3v2/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 ~hppa ppc ppc64 ~riscv x86"
DEPEND="media-libs/id3lib"
RDEPEND="${DEPEND}"
src_prepare() {
default
emake clean
}
src_configure() {
tc-export CC CXX
}
src_install() {
dobin id3v2
doman id3v2.1
einstalldocs
}