You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-sound/pwavecat/pwavecat-0.4.5.ebuild

32 lines
629 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit flag-o-matic toolchain-funcs
DESCRIPTION="Concatenates any number of audio files to stdout"
HOMEPAGE="https://www.panteltje.nl/panteltje/dvd/"
SRC_URI="https://www.panteltje.nl/panteltje/dvd/${P}.tgz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
PATCHES=(
"${FILESDIR}"/${P}-Makefile.patch
"${FILESDIR}"/${P}-version.patch
"${FILESDIR}"/${P}-overflow.patch
"${FILESDIR}"/${P}-fno-common.patch
)
src_configure() {
append-lfs-flags
tc-export CC
}
src_install() {
dobin pwavecat
einstalldocs
}