You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-sound/volwheel/volwheel-0.2.9.ebuild

26 lines
577 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit xdg
DESCRIPTION="A volume control trayicon with mouse wheel support"
HOMEPAGE="https://oliwer.net/b/volwheel.html"
SRC_URI="https://github.com/oliwer/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 ~mips x86"
IUSE="alsa"
DEPEND="dev-lang/perl"
RDEPEND="${DEPEND}
dev-perl/Gtk2
alsa? ( media-sound/alsa-utils )"
src_install() {
./install.pl prefix="${EPREFIX}"/usr destdir="${D}" || die
einstalldocs
}