You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-tv/dvbstream/dvbstream-0.7_pre20080516-r...

65 lines
1.5 KiB

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit toolchain-funcs
DESCRIPTION="RTP multicast stream server and other tools for DVB cards"
HOMEPAGE="https://sourceforge.net/projects/dvbtools"
MY_P="${PN}-snapshot-20080302"
SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
RDEPEND="dev-lang/perl"
DEPEND="sys-kernel/linux-headers"
S="${WORKDIR}/${PN}"
PATCHES=(
"${FILESDIR}/${P}-update.diff"
"${FILESDIR}/${PN}-0.7_pre20080302-telnet-port-switch.diff"
)
src_prepare() {
default
sed -i Makefile \
-e 's:$(CFLAGS):$(CFLAGS) $(CPPFLAGS):' \
-e '/CFLAGS.*=.*-g -Wall -O2/s:-g -Wall -O2::' \
-e '/CFLAGS.*=/s:CFLAGS:CPPFLAGS:' \
-e 's:-I \.\./DVB/include:-I /usr/include:' \
-e 's:$(CC):$(CC) $(LDFLAGS):g' \
|| die 'failed to fix flags in the Makefile'
sed -e 's:\./svdrpsend.pl:dvbstream-send.pl:' \
-i TELNET/*.sh \
|| die 'failed to rename the svdrpsend.pl command in scripts'
sed -e 's:^DUMPRTP=.*$:DUMPRTP=dumprtp:' \
-e 's:^TS2ES=.*$:TS2ES=ts2es:' \
-i *.sh \
|| die 'failed to set DUMPRTP and TS2ES in scripts'
}
src_compile() {
emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
}
src_install() {
dobin dvbstream dumprtp rtpfeed ts_filter
newbin TELNET/svdrpsend.pl dvbstream-send.pl
dodoc README*
newdoc TELNET/README README.telnet
insinto "/usr/share/doc/${PF}/tune"
doins TELNET/*.sh
insinto "/usr/share/doc/${PF}/multicast"
doins *.sh
}