You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-video/bino/bino-2.0.ebuild

35 lines
597 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit cmake xdg
DESCRIPTION="Stereoscopic and multi-display media player"
HOMEPAGE="https://bino3d.org/"
SRC_URI="https://bino3d.org/releases/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64"
RDEPEND="
dev-qt/qtbase:6[gui,opengl,widgets]
dev-qt/qtmultimedia:6
dev-qt/qtsvg:6
"
DEPEND="${RDEPEND}"
BDEPEND="
dev-qt/qttools:6[linguist]
virtual/pandoc
"
src_compile() {
local mycmakeargs=(
# Unpackaged
-DCMAKE_DISABLE_FIND_PACKAGE_QVR=ON
)
cmake_src_configure
}