You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-video/tcmplex-panteltje/tcmplex-panteltje-0.4.7-r2....

36 lines
650 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit toolchain-funcs
DESCRIPTION="Audio video multiplexer for 8 audio channels"
HOMEPAGE="http://panteltje.com/panteltje/dvd/"
SRC_URI="http://panteltje.com/panteltje/dvd/${P}.tgz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
PATCHES=(
"${FILESDIR}"/${P}-clang16.patch
)
src_prepare() {
default
sed -e "s:CFLAGS = -O2:CFLAGS += \$(CPPFLAGS):" \
-e "s:\$(LIBRARY):\$(LIBRARY) \$(LDFLAGS):" \
-i Makefile || die
}
src_compile() {
emake CC="$(tc-getCC)"
}
src_install() {
dobin tcmplex-panteltje
einstalldocs
}