You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/calamaris/calamaris-2.99.4.5.ebuild

38 lines
752 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="parses logfiles of a wide variety of web proxy servers and generates reports"
HOMEPAGE="https://cord.de/calamaris-english"
SRC_URI="https://cord.de/files/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~x86"
IUSE="selinux"
RDEPEND="
dev-lang/perl
dev-perl/GDGraph
selinux? ( sec-policy/selinux-calamaris )
"
src_prepare() {
default
sed -i \
-e "s:\(use lib\).*$:\1 '/usr/share/';:" \
calamaris || die
}
src_install() {
dobin calamaris calamaris-cache-convert
insinto /usr/share/${PN}
doins *.pm
doman calamaris.1
dodoc BUGS CHANGES EXAMPLES EXAMPLES.v3 README TODO calamaris.conf
}